여러 버전 프로그램 설치시 연결프로그램 설정 변경(레지스트리 변경)

레지스트리 변경에 대해서 잘 모르시는 분들은 이 방법을 추천하지 않습니다.

레지스트리 변경을 잘못하면 윈도우에 심각한 문제가 발생할 수도 있습니다.

레지스트리 변경에 관해 조금이라도 아시는 분들만 시도하시길 바랍니다.

그리고 레지스트리 값은 컴퓨터에 따라 약간씩 다를 수 있기 때문에 아래 과정은 참고만 하시기 바랍니다.


3D프로그램인 마야를 2011, 2013버전 두 가지를 깔아서 사용하고 있다.

2013이 최신 버전이고, 최근에 설치해서 탐색기에서 마야 파일을 더블 클릭 시 2013이 자동으로 실행됐다.

더블 클릭시 2011이 실행돼야 할 상황이라 방법을 찾아보다 레지스트리를 변경했다.


처음엔 시스템 환경 변수를 이리저리 설정해봤지만 통하질 않았다.


윈도우 실행창(윈도우단축키+R)에서 regedit를 실행.


검색(Ctrl+F)에서 maya.exe를 검색.


아마도 먼저 뜨는 게 아래 경로일 거다.

\HKEY_CLASSES_ROOT\Applications\maya.exe

확인해보니 이 경로는 파일을 마우스 오른쪽 버튼 눌러서 연결프로그램 설정하면,

그 값이 저장되는 것 같은데- 이건 바꿔도 제대로 적용이 안 되더라.


그래도 혹시 모르니깐

maya.exe\shell\open\command 폴더에 있는

키값을 변경해주자.

기존: "C:\Program Files\Autodesk\Maya2013\bin\maya.exe" -file "%1"

변경: "C:\Program Files\Autodesk\Maya2011\bin\maya.exe" -file "%1"

이것만 해서 안 될 거다. 내가 레지스트리를 검색했을 땐 이미 바뀌어있었다.- _-;


F3(다음 찾기)을 눌러서 더 검색해본다.


다음에 뜨는 경로.

\HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache

이 폴더 안에

C:\Program Files\Autodesk\Maya2013\bin\maya.exe

라는 이름이 있다!

하지만 이걸 바꿔도 역시 안 되더라. 그냥 마야 2013이 실행됨. - _-;

그래도 혹시 모르니깐 이것도 바꾸긴 하자.

위에 이름을 선택한 다음에 F2를 눌러서 2011로 변경.


다시 F3.


\HKEY_CLASSES_ROOT\MayaAsciiFile\DefaultIcon


!!!

뭔가 입질이 왔다!


마야 아스키(.ma) 파일의 아이콘 이미지 경로다!

이건 어차피 아이콘 이미지 경로이기 때문에 별 상관없으니 그냥 내버려 두고,

바로 밑에 있는 

\shell 폴더를 보자.

edit\command는 워드패드 연결이니 그냥 두고.

open\command !!

이거다. ㅠㅠ

데이터값이 

"C:\Program Files\Autodesk\Maya2013\bin\maya.exe" -file "%1"

로 되어있다.

2011로 변경하자.

Render\command 도 마찬가지로 변경하자. (렌더링하다가 충돌 일으킬지도 모르니)


자 이제 한번 더 F3을 누르면 

정말 원하던 \MayaBinaryFile 이 나온다!!! 

mb 파일에 관련된 그것!!

위에 설명대로 요것도 바꿔주자.


좀 더 검색해보면,

\MayaEnvFile (이건 실행하고 상관없으니 패스)

\MayaScriptFile (이건 혹시 모르니 위처럼 변경)

\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\maya.exe 

(음. 이건 맨 처음 나왔던 것과 유사한데, 정확히 어떤 차이가 있는지는 모르겠다. 혹시 모르니 변경.)


여기까지 진행하고 재부팅을 한다.

그리고 마야 파일을 더블 클릭해서 실행해보자.


올레~ 2011로 실행된다!!



위의 방법이 정확하게 맞는 방법인지는 모르겠지만,

일단 해결은 했다.


설정

트랙백

댓글

어도비 일러스트레이터 실행이 안 될 경우.

Apple | iPhone 4S | 1/20sec | F/2.4 | 4.3mm | ISO-80


오랜 만에 일러스트레이터를 켰더니 위 상태에서 실행이 안 된다.
처음에는 원인을 알지 못해서 일러스트만 지웠다가 다시 깔아보고,
어도비 마스터 콜렉션 전체를 지웠다가 다시 깔아보았지만, 여전히 저 상태로 실행이 안 됐다.

지인들에게 물어본 결과,
원인은 '폰트'

그러고 보니 최근에 추가로 설치한 폰트가 있었는데,
딱 그 이후 처음으로 실행을 한 것이다.

지인들의 조언대로 일단 윈도우의 폰트 폴더로 가서 가장 최근에 설치한 폰트를 지웠다.


가장 최근 날짜에 설치된 폰트만 지우고 다시 일러스트를 실행해 보니,
일러스트 실행이 잘 된다!!!

그리고,
지인이 추가로 해준 조언에 따르면
일러스트레이터 설정에서 폰트 표시를 영어로 지정해 놓으면 그런 에러가 잘 안 일어난다고 해서
그 설정도 변경했다.

설정 경로 [ Edit - Preferences - Type ]

'Show Font Names in English'에 체크한다.


위와 같이 설정을 바꾼 다음에
지웠던 폰트를 다시 설치하고 일러스트를 실행해 보니 잘 된다!!


설정

트랙백

댓글

  • 2013.02.13 23:33 ADDR 수정/삭제 답글

    비밀댓글입니다

  • 유병철 2015.01.30 21:45 신고 ADDR 수정/삭제 답글

    덕분에 감사합니다 :)

  • 감사합니다 2015.10.12 11:41 신고 ADDR 수정/삭제 답글

    덕분에 문제를 해결했습니다 ㅠㅠㅠㅠ감사합니다